Шери

apachesolr

Установка и настройка apachesolr 4 multicore для drupal в ubuntu 12.04

Перво-наперво проверяем версию JAVA java -version Для SOLR => 4 должна быть JAVA 7 (1.7.0_60) или выше.

java version "1.7.0_60"
Java(TM) SE Runtime Environment (build 1.7.0_60-b19)
Java HotSpot(TM) Client VM (build 24.60-b09, mixed mode)

Качаем отсюда http://archive.apache.org/dist/lucene/solr/ или отсюда http://www.eu.apache.org/dist/lucene/solr/ любую версию solr

wget http://archive.apache.org/dist/lucene/solr/4.9.0/solr-4.9.0.tgz
tar zvxf solr-4.9.0.tgz
cp -R solr-4.9.0/ /opt/solr
cp solr-4.9.0/example/webapps/solr.war /opt/solr/